Back to overview
Movement
Jan 29 at 08:29am HST
Resolved
Jan 29 at 08:29am HST
The DNS server that we use are being changed and updated, we do understand ther will be downtime do to this.
Affected services
Resolved
Jan 29 at 08:29am HST
The DNS server that we use are being changed and updated, we do understand ther will be downtime do to this.
Affected services